Farm Merge Valley - Yahoo US - Outage – Incident details

Facebook experiencing degraded performance

Yahoo US - Outage

Resolved
Major outage
Started about 2 months agoLasted about 4 hours

Affected

Yahoo US

Major outage from 4:49 PM to 9:05 PM

Updates
  • Resolved
    Resolved

    The login issue has been fixed. Please log out and log back in to your Yahoo account to ensure everything works properly! As a token of our appreciation for the login outage that lasted over a day, players can claim the daily challenge rewards by using the following code: YAHOO2. Welcome back!

  • Investigating
    Investigating

    Hello Farmers! Yahoo US is currently experiencing another outage, which is preventing players from logging in to our servers. We are in contact with their team and are awaiting a fix on their side. We will keep you informed as soon as we have any updates. Thank you for your patience and understanding!